Frequently Asked Questions

Technical Support


What are the minimum computer requirements in order to play?

In order to play the various games on Deal or No Deal Bingo if  your computer is  less than 5 years old then you should have absolutely no problems playing bingo with us. To play bingo Macromedia Flash Player version 8.0 must be installed on your PC. If this version of the player is not already installed, when you access the game you will be prompted to download the player at no charge. The bingo application can be played using Internet Explorer version 4.0 or above. To ensure the bingo game performs at its optimum level please close all unwanted programs and minimise any programs that you are not actively using. Cookies must be enabled on your web-browser.